Cluster A SMTP errors

Incident Report for OpenSRS

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 02:53 UTC

Monitoring

Our Engineers have identified the issue and implemented a fix.

Services have recovered at this time and we'll continue to monitor.

Start: 2026-07-02 00:37 UTC
End: 2026-07-02 01:50
Posted Jul 02, 2026 - 01:58 UTC

Investigating

We are aware of an issue affecting Cluster A involving

Our engineers have been engaged and are investigating
Posted Jul 02, 2026 - 01:21 UTC
This incident affected: Hosted Email (Cluster A, Webmail).