inbound delay - Cluster A
Incident Report for OpenSRS
Resolved
A fix has been implemented and the issue for the email delays is now be resolved.


Incident Start Time: 03-17-2021 14:40:00
Incident End Time:03-17-2021 20:50:00
Total Duration:6 hours, 10 minutes
Posted Mar 17, 2021 - 21:43 UTC
Update
Our engineering team continues to investigate the root cause of the issue and we will continue to provide updates.
Posted Mar 17, 2021 - 19:47 UTC
Update
Our engineering team continues to work on managing the queue buildup and improving mail delivery time.

We will provide updates as they are available.
Posted Mar 17, 2021 - 18:00 UTC
Identified
Our engineering team is currently implementing a configuration to ease traffic. We expect improved performance and will provide updates on the progress.
Posted Mar 17, 2021 - 16:24 UTC
Investigating
We are currently experiencing inbound delays for some users due to a queue buildup. Our engineering team are investigating to determine the root cause and working to improve the situation.
Posted Mar 17, 2021 - 15:19 UTC
This incident affected: Hosted Email (Cluster A).