Identity Digital Registry Connection (.me .info .io .ai)

Incident Report for OpenSRS

Update

Our engineers are investigating with the registry about the possible cause.
Posted Aug 05, 2026 - 21:12 UTC

Investigating

We are currently experiencing connection issues with the Identity Digital registry. Our engineering team is investigating the issue.

This affects registrations, renewals, and management of .me, .info, .io, and .ai domains. Existing domains will continue to resolve normally.
Posted Aug 05, 2026 - 19:04 UTC
This incident affects: Domain Services (Other gTLDs, Other ccTLDs).