Cluster B Login Issues

Incident Report for OpenSRS

Resolved

The issues for Cluster B have now been resolved.
Posted Apr 26, 2025 - 10:48 UTC

Investigating

Some email users may experience issues/errors when attempting to log in to email via Cluster B. Our engineers are aware of the situation and are working to resolve as quickly as possible. We appreciate your patience.
Posted Apr 26, 2025 - 10:43 UTC
This incident affected: Hosted Email (Cluster B, Webmail).