Tucows Domains Whois Lookups
Incident Report for OpenSRS
Resolved
We are happy to report that whois services have been restored and are no longer being rate-limited.

Start Time: 2024-02-05 15:14
End Time: 2024-02-05 19:43
Posted Feb 05, 2024 - 21:07 UTC
Investigating
Whois searches via https://tucowsdomains.com/whois-result/ are throwing an error of 'Maximum Daily connection limit reached. Lookup refused'. Our engineers are working to resolve this matter. Further updates will be provided.
Posted Feb 05, 2024 - 16:07 UTC
This incident affected: Domain Services (WHOIS).