Nominet Registry
Scheduled for Sep 11, 18:00 - 21:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted 4 days ago. Aug 21, 2019 - 13:09 UTC
Scheduled
During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates
Posted 17 days ago. Aug 07, 2019 - 19:33 UTC
This scheduled maintenance affects: Domain Services (Core ccTLDs).