Cluster A/B Sending Issue

Incident Report for OpenSRS

Resolved

There was an issue with the antivirus servers, which caused the service to fail and emails to be rejected.

A fix has been implemented, and the Anti-virus services are operational.

This incident has been resolved.
Posted May 12, 2026 - 16:39 UTC

Investigating

Our engineers are investigating an email sending issue impacting cluster A and cluster B users.
Posted May 12, 2026 - 16:18 UTC
This incident affected: Hosted Email (Cluster A, Cluster B, Webmail).