Support Calls
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted Jan 12, 2021 - 15:58 UTC
Investigating
We're currently experiencing difficulties reaching our supportdesk call service provider.

We're working with them to resolve the issue.

In the interim, resellers can still contact us via the chat feature at opensrs.com, or email via help@opensrs.com
Posted Jan 12, 2021 - 15:03 UTC
This incident affected: Reseller Support.