Digicert Certificate Authority
Incident Report for OpenSRS
Resolved
The issue has now been resolved.
Posted 20 days ago. Jun 28, 2019 - 06:57 UTC
Investigating
Digicert is currently experiencing technical issues accepting and processing SSL orders. Their operations team is investigating the issue. This includes GeoTrust, Thawte and Symantec orders.

This will affect enrolments, renewals, replacements and revocations of orders during this time.

Their Operations is currently estimating this to be resolved by 6:30am UTC Friday June 28th.
Posted 20 days ago. Jun 28, 2019 - 04:44 UTC
This incident affected: SSL.