Identity Digital Registry Connection
Incident Report for OpenSRS
Resolved
Our engineers have implemented a fix for the Identity Digital Registry Connection problems.

The following services have been restored:
Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

Start Time: 03/27/2024 18:27 UTC
End Time: 22:42 UTC
Posted Mar 27, 2024 - 23:21 UTC
Investigating
We are currently investigating an issue after the scheduled maintenance from Identity Digital Registry, which completed at 12:00 UTC today. The following services are being affected at this time:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

These domains continue to resolve.

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart
Posted Mar 27, 2024 - 20:04 UTC
This incident affected: Domain Services (Other gTLDs, Other ccTLDs).