OpenSRS Website
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 22:42 UTC
Investigating
There are currently issues with loading the opensrs.com website. We are working on getting this resolved. Reseller services are unaffected.
Posted Sep 18, 2024 - 22:38 UTC