Network Connections to OpenSRS
Incident Report for OpenSRS
Postmortem

Incident Date: September 6, 2020
Incident Number: PR-1305

On September 6, 2020 at 12:27 PM ET, Tucows’ experienced a service degradation impacting Tucows Domains and Ting platforms. 

The service degradation was due to a DDoS attack.  

At 1:16 PM ET, Tucows Engineering teams mitigated the issue by blocking the offending traffic to stabilize theTucows Domains and Ting platforms. 

Tucows revised internal processes and implemented dynamic rules and thresholds to auto-mitigate DDoS attacks in a timely manner.

Tucows to further review and enhance the overall security against malicious traffic.

Thank you,

Tucows Engineering Team

Posted Sep 10, 2020 - 14:42 UTC

Resolved
All the services have been working successfully and no further impact has been observed

Incident Start Time: 09-06-2020 16:30:00 UTC
Incident End Time:09-06-2020 17:16:00 UTC
Total Duration:46 minutes
Posted Sep 06, 2020 - 18:00 UTC
Monitoring
Our operations team has worked to mitigate DDOS attacks against OpenSRS services. Service has stabilized but we continue to monitor to ensure services are fully functional.
Posted Sep 06, 2020 - 17:25 UTC
Investigating
We are currently investigating DDOS attacks against OpenSRS services, customers may experience slow down and support services are currently impacted.
Posted Sep 06, 2020 - 16:54 UTC