Cluster A - Webmail Login
Incident Report for OpenSRS
Postmortem

Incident Date: November 4, 2021
Incident Number: PR-2546 

On November 4, 2021, at 9:52 AM ET, Tucows’ hosted email platform experienced service interruption impacting POP/IMAP/Webmail for Prod A. 

The service interruption was due to the high number of established connections on the Webmail database in the legacy hosted email platform. 

At 10:12 AM ET, The engineering team increased the connection limits and restarted the Webmail database to reset the connection. All the services were restored successfully.

Tucows is in the process of investigating the root cause and developing a plan to roll out a permanent solution to address the issue.

Tucows is committed to continue with the hosted email migration efforts into the new cloud to maintain a scalable and stable hosted email environment.

Thank you,

Tucows Engineering Team

Posted Nov 09, 2021 - 19:11 UTC

Resolved
This issue was caused by too many connections to our database. Our engineers increased the maximum number of database connection permitted, which resolved the issue.

Incident Start Time: 11-04-2021 13:52:00
Incident Start Time:11-04-2021 14:12:00
Total Duration: 20 minutes
Posted Nov 04, 2021 - 14:24 UTC
Investigating
We are investigating an issue preventing some users on Cluster A from logging into Webmail. Our engineering team has been engaged.

We will provide an update once we have additional information.
Posted Nov 04, 2021 - 14:00 UTC
This incident affected: Hosted Email (Cluster A).