Geotrust Connection Degradation
Incident Report for OpenSRS
Resolved
Geotrust has implemented a fix and resolved their issue. Service should be operational again and Geotrust orders can now be processed.
Posted Nov 01, 2019 - 18:56 UTC
Investigating
We are currently experiencing connection issue with Digicert/Geotrust. Geotrust portal is inaccessible currently. Geotrust orders that requires action to be performed by the certificate authority can be unsuccessful. We have reached out to inquire and will update when we have more information.
More details can be found at the providers status page: https://websitesecurity.status.digicert.com/
Posted Nov 01, 2019 - 18:16 UTC
This incident affected: SSL.