.it Registry Connection
Incident Report for OpenSRS
Resolved
Registry connections for .it have now been restored. Thank you for your patience.

Incident Start Time: 02-04-2021 05:44:00 UTC
Incident End Time:02-04-2021 07:00:00 UTC
Total Duration:~1 hr 16mins
Posted Feb 04, 2021 - 07:15 UTC
Update
We are continuing to investigate this issue.
Posted Feb 04, 2021 - 06:38 UTC
Investigating
We are currently experiencing an incident that is impacting .it domains in regards to registrations and renewals. We have contacted the registry for further investigation. Updates will be provided as soon as they are available.
Posted Feb 04, 2021 - 06:30 UTC
This incident affected: Domain Services (Core ccTLDs).