OpenSRS Chat Support

Incident Report for OpenSRS

Resolved

This incident has been resolved.
Posted Apr 26, 2023 - 18:44 UTC

Identified

OpenSRS chat support may not be available at the moment due to technical issues at the service provider.

Please reach out to us directly via phone or email.
https://opensrs.com/contact-support/

Our apologies for the inconvenience.
Posted Apr 26, 2023 - 17:28 UTC
This incident affected: Reseller Support.