.CA Registry Connections
Incident Report for OpenSRS
Resolved
This maintenance has been completed, and .CA domains are now fully manageable.
Posted Jun 18, 2021 - 07:49 UTC
Identified
This registry connection issue has found to be from the .CA registry performing a registry maintenance, scheduled to complete at 07:00 UTC. We will provide updates if this ETA changes or when it has completed.
Posted Jun 18, 2021 - 04:23 UTC
Update
We are continuing to investigate this issue.
Posted Jun 18, 2021 - 03:42 UTC
Investigating
We are currently experiencing connection issues with the .CA registry. Our engineering team is contacting the registry for further details.

This affects registrations, renewals, and management of .CA domains. Existing domains will continue to resolve normally.
Posted Jun 18, 2021 - 03:37 UTC
This incident affected: Domain Services (Core ccTLDs).