Cluster B - Deferred Inbound Email.
Incident Report for OpenSRS
Resolved
We have not received any further reports for this issue. All the services have recovered successfully.

Incident Start Time: 11-11-2020 18:15:00 UTC
Incident End Time:11-11-2020 18:42:00 UTC
Total Duration:~27 mins
Posted Nov 11, 2020 - 19:56 UTC
Monitoring
The issue was related to a change made to our spam filter. That change has been reversed and we are monitoring the impact.

Next Update: Within 60 minutes
Posted Nov 11, 2020 - 18:57 UTC
Investigating
We are currently experiencing an issue where some users may notice some of their inbound email deferred.

The problem is being investigated and updates will be posted as soon as possible
Posted Nov 11, 2020 - 18:35 UTC
This incident affected: Hosted Email (Cluster B).