Cluster A and B Inbound and Outbound delays.
Incident Report for OpenSRS
Resolved
The engineering team has restored services on Cluster A and B. There won't be any further interruptions to the email services.
We thank you for your patience.

Incident Start Time: 07-21-2021 06:20:00
Incident End Time:07-21-2021 08:00:00
Total Duration:1 hour and 40 minutes
Posted Jul 21, 2021 - 08:14 UTC
Investigating
We are currently experiencing an incident that is impacting Hostedemail, ( Cluster A and B ). Some users will experience delays in outbound and inbound emails. The engineering team has been engaged and they are currently looking into this issue.
Posted Jul 21, 2021 - 06:51 UTC
This incident affected: Hosted Email (Cluster A, Cluster B, Webmail).