Cluster B Login Issues

Incident Report for OpenSRS

Resolved

The Login issues with Cluster B have now been corrected.

Start Time - 0948 UTC
End Time - 1054 UTC
Posted Aug 06, 2026 - 10:55 UTC

Investigating

We are currently investigating reports of email login issues affecting some customers on Cluster B - Webmail/IMAP/POP.
Our team is actively working to identify the cause and restore normal service as quickly as possible. We will provide further updates as more information becomes available.
Posted Aug 06, 2026 - 09:48 UTC
This incident affected: Hosted Email (Cluster B, Webmail).