Cluster A - Inbound/Outbound Issue
Incident Report for OpenSRS
Resolved
The issue has been resolved after a change was reverted by the engineering team.

Incident Start Time: 07-28-2022 20:18:00 UTC
Incident End Time: 07-28-2022 21:00:00 UTC
Total Duration: 42 minutes
Posted Jul 28, 2022 - 21:24 UTC
Investigating
Some users may experience issues with inbound and outbound mail on Cluster A. Our engineering team is investigating the issue.

We will provide an update once we have additional information.
Posted Jul 28, 2022 - 21:07 UTC
This incident affected: Hosted Email (Cluster A).