Payment Processor
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 17:20 UTC
Identified
We've now completed the background updates, and are actively monitoring payments. We see submissions completing as intended, and are monitoring this service closely.
Posted Mar 27, 2024 - 16:06 UTC
Investigating
We are currently experiencing a payment processing issue related to our background updates. This is being actively worked on, and we are working to resolve this with a target of one hour. We will post any updates as they are available.
Posted Mar 27, 2024 - 15:29 UTC
This incident affected: Control Panels (Payment Gateway).