Cluster A - Maintenance
Incident Report for OpenSRS
Resolved
This maintenance has now completed.
Posted Mar 11, 2021 - 06:10 UTC
Investigating
We are currently performing an unscheduled maintenance on Cluster A. This will cause short interruptions of service intermittently during this time.

Maintenance Start Time: 03-11-2021 05:30:00 UTC
Maintenance End Time: 03-11-2021 06:15:00 UTC
Posted Mar 11, 2021 - 05:30 UTC
This incident affected: Hosted Email (Cluster A).