.EU Registry Connections
Incident Report for OpenSRS
Resolved
This incident has been resolved. EU domains may now be registered, renewed, and managed.
Posted Oct 01, 2024 - 15:28 UTC
Investigating
We are currently experiencing connection issues with the .EU registry. Our engineering team is investigating the issue.

This affects registrations, renewals, and management of .EU domains. Existing domains will continue to resolve normally.
Posted Oct 01, 2024 - 15:22 UTC
This incident affected: Domain Services (Other ccTLDs).