DNS resolution outage .SHOP

Incident Report for OpenSRS

Resolved

The DNS resolution issues affecting .shop domain names have been fully resolved.
Our registry partner, GMO Registry, successfully addressed the issue on their side. All systems have returned to normal, and DNS resolution has been completely stable since September 24, 2026, at 21:54 UTC.

Start Time 0:16 UTC
End Time 21:54 UTC
Posted Sep 25, 2026 - 07:09 UTC

Investigating

The .SHOP TLD is experiencing DNS resolution issues at the Registry level, affecting all resellers who sell .shop domains.

We are in contact with GMO Registry, and they are actively investigating the issue on their side.

We'll provide updates as we get them.
Posted Sep 25, 2026 - 00:16 UTC