Digicert SSL Orders Support

Incident Report for OpenSRS

Resolved

Our issue regarding order processing support for Digicert SSL orders has been resolved.
Posted Sep 23, 2025 - 20:35 UTC

Investigating

We are currently unable to provide order processing support (reissue, revoke, status) for Digicert SSL orders. We have contacted Digicert to resolve this matter. This does not impact SSL ordering (control panel/API) or issued certificates.
Posted Sep 23, 2025 - 19:19 UTC
This incident affected: Reseller Support.