Cluster A Inbound Mail Delays
Incident Report for OpenSRS
Resolved
We are happy to report that the inbound email delays and webmail slowness issues with Cluster A have been resolved. Thank you for your patience during this event, and we apologise for the inconvenience.
Posted 4 months ago. Aug 01, 2017 - 20:20 UTC
Update
Our operations team has resolved the issue with the outbound email delays, and are continuing to work on the inbound email delays and webmail slowness. Thank you for your continued patience, and we apologise for the inconvenience.
Posted 4 months ago. Aug 01, 2017 - 16:15 UTC
Update
Our operations team continues to work on the email delays on Cluster A. Users may experience 30 - 60 minute delays on inbound mail and 8 - 12 minute delays on outbound mail as well as webmail slowness. We appreciate your patience as we work to resolve the matter as quickly as possible.
Posted 4 months ago. Aug 01, 2017 - 15:26 UTC
Identified
The expected average inbound mail delivery delay has increased to between 30 and 60 minutes. Our operations team continues to work towards alleviating the issue.

We'll continue to provide updates as we progress towards resolution.
Posted 4 months ago. Aug 01, 2017 - 12:25 UTC
Investigating
Our operations team is currently investigating inbound mail delivery delays for hostedemail services on Cluster A. The delay time will vary depending on the sending mail providers retry policy. For providers with typical retry policies the delay is under 15 minutes.
Posted 4 months ago. Aug 01, 2017 - 11:07 UTC
This incident affected: Hosted Email (Cluster A).