Cluster B Email Issues

Incident Report for OpenSRS

Resolved

The Cluster B Mail issues have now been resolved. All services are now working correctly.

Start time 03:20 UTC
End Time 05:20 UTC
Posted Jun 19, 2025 - 05:26 UTC

Investigating

We are currently experiencing issues with email on Cluster B. Our Engineers are aware and investigating. We will update you shortly, and appreciate your patience.
Posted Jun 19, 2025 - 03:53 UTC
This incident affected: Hosted Email (Cluster B, Webmail).