Webmail Degradation - Cluster A
Incident Report for OpenSRS
Resolved
We have resolved the issues with Webmail for cluster A. Thank you for your patience.
Posted 4 days ago. Sep 12, 2019 - 17:00 UTC
Update
We are continuing to investigate this issue.
Posted 4 days ago. Sep 12, 2019 - 16:27 UTC
Investigating
We have received a few reports of issues with Webmail on cluster A.

All Users may experience slow load times and/or login failures.

We're investigating and will keep you posted.
Posted 4 days ago. Sep 12, 2019 - 16:01 UTC
This incident affected: Hosted Email (Cluster A, Webmail).