Connection with .Asia/.Me/.XXX registry
Incident Report for OpenSRS
Resolved
We are happy to report that this incident is now resolved.
Posted 3 months ago. Jun 01, 2019 - 17:58 UTC
Investigating
We are currently experiencing an issue with the .Asia/.Me/.XXX connection. Our operations team is investigating the issue.
During this time given TLD's will not be able to complete registration.
Posted 3 months ago. Jun 01, 2019 - 17:47 UTC
This incident affected: Domain Services (Other ccTLDs).