Cluster A - Webmail Login
Incident Report for OpenSRS
Postmortem

Incident Date: November 2, 2021
Incident Number: PR-2528 

On November 2, 2021, at 2:22 PM ET, Tucows’ hosted email platform experienced service interruption impacting POP/IMAP/Webmail for Prod A. 

The service interruption was due to the high number of established connections  on the Webmail database in the legacy hosted email platform. 

At 2:35 PM ET, The engineering team restarted the Webmail database to reset the connection. All the services were restored successfully.

At 3:40 PM ET, Tucows encountered another service interruption impacting email services in Prod A. 

At 3:57 PM ET, All the affected services recovered successfully without any intervention.

Tucows is in the process of investigating the root cause and develop a plan to roll out a permanent solution to address the issue.

Tucows is committed to continue with the hosted email migration efforts into the new cloud to maintain a scalable and stable hosted email environment.

Thank you,

Tucows Engineering Team

Posted Nov 08, 2021 - 16:30 UTC

Resolved
Services are restored once again, our engineers will be conducting a full investigation and we will provide a full post mortem at a later date once they we have completed the investigation.

Incident Start Time: 11-02-2021 15:40:00
Incident Start Time:11-02-2021 15:57:00
Total Duration: 17 minutes
Posted Nov 02, 2021 - 20:17 UTC
Investigating
We are investigating an issue preventing some users on Cluster A from logging into Webmail. IMAP and POP services are unaffected. Our engineering team has been engaged.

We will provide an update once we have additional information.
Posted Nov 02, 2021 - 19:57 UTC
This incident affected: Hosted Email (Cluster A).