Hosted Email Cluster A Web and Mail Client (IMAP) login

Incident Report for OpenSRS

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 03:08 UTC

Investigating

We are investigating issues with Cluster A on HostedEmail. Customers may experience issues with logging into webmail, or receiving timeouts/errors using POP/IMAP.
Posted Dec 01, 2025 - 02:26 UTC
This incident affected: Hosted Email (Cluster A).