Increased Latency & Error Rates in OpenSRS API

Incident Report for OpenSRS

Resolved

The latency issue being experienced with the API has been resolved.

Our Engineers will maintain their monitoring.
Posted Jan 29, 2026 - 22:43 UTC

Monitoring

Service has returned to operational level. We will continue to monitor performance.
Posted Jan 29, 2026 - 22:01 UTC

Identified

We are monitoring the performance of our services while engineers continue work on a solution. Users may still experience periods of slowness and errors.
Posted Jan 29, 2026 - 18:59 UTC

Investigating

Users attempting to interact with the API may experience periods of increased latency, errors, and timeouts. Engineers have been engaged and are investigating.
Posted Jan 29, 2026 - 16:39 UTC
This incident affected: APIs (OpenSRS API).