Domains, Corporate, Hostedemail, API, Auth, Hover, IMAP, Inbound/Outbound Mail, HRS, OpenSRS, Prod A, POP, UWP/AWI, Webmail.
Incident Report for OpenSRS
Postmortem

Incident Date: March 25, 2021
Incident Number: PR-1838

On March 25, 2021 at 6:17 AM ET, we experienced service interruption with Tucows’ Domains and Hosted email platform impacting Webmail in Prod A.

The service interruption was caused due to high volume of traffic causing network congestion.

At 7:20 AM ET, The network congestion subsided and all the services recovered successfully without any intervention. 

Tucows is to further investigate the root cause of the issue. 

Thank you,

Tucows Engineering Team

Posted Apr 01, 2021 - 18:36 UTC

Resolved
All services are now operational.

Incident Start Time: 03-25-2021 10:17:00 UTC
Incident End Time:03-25-2021 11:20:00 UTC
Total Duration:1 hour, 3 minutes
Posted Mar 25, 2021 - 11:48 UTC
Update
The network congestion has subsided and most services have recovered. The root cause is still being investigated and the remaining degraded services are also being restored. As most services have recovered.
We will update once all services have recovered. Thank you again for your patience.
Posted Mar 25, 2021 - 11:15 UTC
Investigating
We are currently experiencing an incident that is impacting Domains, Corporate, Hostedemail, API, Auth, Hover, IMAP, Inbound/Outbound Mail, HRS, OpenSRS, Prod A, POP, UWP/AWI, Webmail. There appears to be internal network congestion at the data center. This is causing all services there to be significantly degraded. Multiple engineering teams have been engaged to investigate and alleviate this issue, however at this time the root cause is unknown.
We will continue to investigate and update as soon as we have more information. We thank you for your patience.
Posted Mar 25, 2021 - 10:51 UTC
This incident affected: Control Panels (Reseller Control Panel, Classic RWI, End User Control Panel, Storefront, Payment Gateway), Domain Services (Core gTLDs, Core ccTLDs, Other gTLDs, Other ccTLDs, Premium Names, WHOIS), APIs (OpenSRS API, OpenHRS API, Email API), Hosted Email (Cluster A, Cluster B, Webmail), and Reseller Support.