Cluster B - Webmail Login

Incident Report for OpenSRS

Resolved

Our engineers have applied a fix, and confirmed webmail for Cluster B is now back to operating as usual.

Started: Tuesday August 19th at 20:40 UTC
Ended: Tuesday August 19th at 21:09 UTC
Posted Aug 19, 2025 - 20:16 UTC

Investigating

We are investigating an issue preventing some users on Cluster B from logging into Webmail. IMAP and POP services are unaffected. Our engineering team has been engaged.

We will provide an update once we have additional information.
Posted Aug 19, 2025 - 19:47 UTC
This incident affected: Hosted Email (Cluster B).