Cluster B - Webmail and IMAP/POP

Incident Report for OpenSRS

Resolved

Our engineers have resolved the issues on cluster B at this time.

Start: 00:30 UTC
End: 02:00 UTC
Posted Sep 11, 2026 - 02:24 UTC

Investigating

We are currently investigating reports of login and connection issues affecting Webmail, IMAP, and POP services.

Our engineers are working the issue and we'll provide further updates as we receive them.
Posted Sep 11, 2026 - 01:49 UTC
This incident affected: Hosted Email (Cluster B, Webmail).