Cluster A - inbound email delay
Incident Report for OpenSRS
Resolved
Our engineering team has enabled the email delivery services and users will be able to receive emails successfully.

Incident Start Time: 07-29-2020 20:08:00 UTC
Incident End Time:07-29-2020 23:19:00 UTC

Total Duration:3 hours and 11 minutes
Posted Jul 29, 2020 - 23:44 UTC
Update
Our Engineering team is continuing their work on the affected storage to alleviate the load spike.
Posted Jul 29, 2020 - 21:25 UTC
Update
One of the network storage is experiencing high load. Engineering team has disabled inbound email deliveries for a subset of users to reduce the load on the affected storage device. The root cause is under investigation.

Subset of users in Cluster A may experience inbound email delivery delays, slowness or timeouts while accessing their email.
Posted Jul 29, 2020 - 20:36 UTC
Investigating
Degradation of service
Posted Jul 29, 2020 - 20:30 UTC
This incident affected: Hosted Email (Cluster A, Webmail).