Externally Managed TLDs
Incident Report for OpenSRS
Resolved
Our engineering team resolved issues with high traffic causing degradation of services relating to externally managed TLDs. We've temporarily increased max connections and the engineering team worked to stop any abusive traffic causing slowdown.

Incident Start Time: 05-11-2021 10:41:00
Incident End Time:05-11-2021 14:15:00
Total Duration:~3hrs 26mins
Posted May 11, 2021 - 14:49 UTC
Investigating
We are currently experiencing issues communicating with our partner registrar(s). These partner registrars() are accredited to purchase and manage domains of certain TLDs on behalf of OpenSRS.

For domains of the impacted TLDs, this following actions will become unavailable:

- registrations
- renewals
- transfers
- modifications

Existing domain registrations should continue to resolve DNS as expected.

For a list of all impacted TLDs click below

https://help.opensrs.com/hc/en-us/articles/206391417-Externally-managed-TLDs
Posted May 11, 2021 - 11:15 UTC
This incident affected: Domain Services (Core ccTLDs, Other gTLDs, Other ccTLDs).