CentralNic is currently down

Incident Report for OpenSRS

Resolved

The connection issues with CentralNic is now resolved.
Posted May 06, 2020 - 01:36 UTC

Investigating

We are currently investigating an issue with CentralNic as their services are currently down.
Our customers will experience issues managing their domains.


We will provide further updates as they become available.
Posted May 06, 2020 - 01:29 UTC
This incident affected: Domain Services (Core gTLDs, Core ccTLDs).