Sectigo SSL Order Errors
Incident Report for OpenSRS
Resolved
Engineering has implemented a fix for the OpenSRS trust services. As a result, Sectigo SSL Orders are now processing normally. This issue is now resolved.
Posted Sep 17, 2024 - 21:20 UTC
Update
This issue impacts our OT&E (Testing) environment as well. Further updates will be provided as our investigation continues.
Posted Sep 17, 2024 - 15:12 UTC
Update
We are continuing to investigate this issue.
Posted Sep 17, 2024 - 11:23 UTC
Update
We are currently still experiencing issues with Sectigo SSL new orders and renewals. Our teams are currently awaiting an update from Sectigo to resolve the issue. We will provide an update when we have more information.
Posted Sep 17, 2024 - 11:22 UTC
Investigating
We are currently experiencing issues with the OpenSRS Trust Orders in the Reseller Control Panel.

Our NoC is engaged and investigating.
Posted Sep 16, 2024 - 17:06 UTC
This incident affected: SSL.