Digicert Outage
Incident Report for OpenSRS
Resolved
This incident has been resolved.

Incident Start Time: 03-15-2023 20:00 UTC
Incident End Time: 03-15-2023 21:25 UTC
Total Duration: 1h 25m
Posted Mar 15, 2023 - 21:30 UTC
Monitoring
Digicert is now monitoring the results of their fix. At this time new orders and renewals should process without issue.
Posted Mar 15, 2023 - 21:00 UTC
Identified
Digicert is currently experiencing a service outage. They have identified the issue and a fix is being implemented.

This outage impacts new orders and renewals. Existing orders are not impacted.
Posted Mar 15, 2023 - 20:38 UTC
This incident affected: SSL.