Chat Support Unavailable
Incident Report for OpenSRS
Resolved
This incident has been resolved and chat support has been restored.
Posted Feb 08, 2024 - 16:02 UTC
Investigating
OpenSRS chat support is currently unavailable. Please contact us directly via phone or email during this period for assistance. Apologies for the inconvenience.
https://opensrs.com/contact-support/
Posted Feb 08, 2024 - 15:43 UTC
This incident affected: Reseller Support.