.DE and .FR Latency

Incident Report for OpenSRS

Resolved

We've monitored our connections for latency and see it's been stable, not affecting .de and .fr domains requests and actions on them.

This incidence has been resolved.
Posted Apr 01, 2026 - 18:26 UTC

Investigating

We are currently experiencing delays when querying and submitting updates for .de and .fr domains. Our engineering team is investigating this at this time.

This affects registrations, renewals, and management of .de and .fr domains. Existing domains will continue to resolve normally.

For a list of affected TLDs, please see: http://opensrs.help/chart
Posted Apr 01, 2026 - 14:30 UTC
This incident affected: Domain Services (Core ccTLDs).