Cluster A Webmail services
Incident Report for OpenSRS
Resolved
The email services in the cluster are now fully restored.
Thank you for your patience.
Posted May 19, 2020 - 01:44 UTC
Update
Our Operations team continues to work on the email issues on our cluster.
Users may still experience slowness or timeouts.
Posted May 19, 2020 - 01:16 UTC
Investigating
We are investigating an issue affecting some users on our Cluster A while accessing Webmail services. Users might experience slowness or time outs while attempting to connect.
Our operations team has been engaged.
We will provide an update once we have additional information.
Posted May 19, 2020 - 00:06 UTC
This incident affected: Hosted Email (Cluster A).