CentralNic Registry Connections
Incident Report for OpenSRS
Resolved
We are happy to report that CentralNic registry connection has been restored. All pending orders may be completed.
Posted 2 months ago. Mar 12, 2019 - 19:56 UTC
Investigating
We are currently experiencing connection issues with the CentralNic registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of CentralNic domains. Existing domains will continue to resolve normally.

For a list of affected TLDs, please see: http://opensrs.help/chart
Posted 2 months ago. Mar 12, 2019 - 19:26 UTC
This incident affected: Domain Services (Other gTLDs).