Cluster B - Webmail Login

Incident Report for OpenSRS

Resolved

This incident has been resolved. All services are operating normally.
Posted Aug 05, 2026 - 19:41 UTC

Update

The incident also impacts IMAP and POP. They are also experiencing slower response times. Our engineering team is actively working on a resolution.
Posted Aug 05, 2026 - 18:03 UTC

Investigating

We are investigating an issue preventing some users on Cluster B from logging into Webmail. IMAP and POP services are unaffected. Our engineering team has been engaged.

We will provide an update once we have additional information.
Posted Aug 05, 2026 - 16:18 UTC
This incident affected: Hosted Email (Cluster B).