.IT Domain Lookup Errors

Incident Report for OpenSRS

Update

Our team is continuing to work with the registry to resolve the issue. This incident may impact new .IT domain registrations, transfers, and domain management operations.

We will provide further updates as soon as we receive additional information from the registry.
Posted Jul 23, 2026 - 19:11 UTC

Investigating

We are currently experiencing errors with .IT domain lookups. Our engineering team is investigating the issue.

Existing domains will continue to resolve normally.
Posted Jul 23, 2026 - 15:52 UTC
This incident affects: Domain Services (Other ccTLDs).