.Museum registry maintenance
Incident Report for OpenSRS
Resolved
The .museum registry had a scheduled system maintenance, during which time the following services were unavailable:

* Availability Checks
* Whois Services
* Domain Purchases
* Domain Renewals
* Domain Updates

This wasn't posted publicly causing but was confirmed when contacting Afnic.

Incident Start Time: 04-15-2021 07:16:00 UTC
Incident End Time: 04-15-2021 07:50:00 UTC
Posted Apr 15, 2021 - 10:21 UTC
Investigating
We are experiencing connection issues to the registry. We will provide an update shortly with additional information.
Posted Apr 15, 2021 - 06:46 UTC
This incident affected: DNS (Domain Forwarding).