Support Chat
Incident Report for OpenSRS
Resolved
After reaching out to our software vendor, they are able to resolve the issue at our end. Live chat is now available at https://help.opensrs.com.
Posted Jun 16, 2020 - 15:09 UTC
Investigating
Users will not be able to chat with support via https://help.opensrs.com/

We ask that until the issue is resolved, chat requests to support are engaged via the help widget at https://opensrs.com/
Posted Jun 10, 2020 - 13:52 UTC
This incident affected: Reseller Support.