Issue impacting .AI, .LLC and .center TLD domains

Incident Report for OpenSRS

Resolved

We have identified and corrected the issue and domain lookups for .ai, .llc and .center are now restored.
Posted Apr 19, 2026 - 12:22 UTC

Investigating

We are currently investigating an issue impacting services for .ai, .llc, and .center domains. Our engineering team is actively working to identify the root cause and restore normal operations as quickly as possible.

We will share additional updates as soon as more information becomes available.
Posted Apr 19, 2026 - 10:55 UTC
This incident affected: Domain Services (Other gTLDs, Other ccTLDs).